Sejam bem vindos!

Este site é feito para auxiliar nas disciplinas ministradas por mim. Agradeço a sua visita.

segunda-feira, 18 de abril de 2011

Disciplina de Algoritmos Computacionais - Algoritmo Portugol

Olá turma, disponibilizarei informações importantes e material de apoio nesse site.

Todos os alunos tem que aprender a escrever um código fonte .gpt no notepad e compilar através do gpt,  mas para que isso possa ocorrer vocês devem instalar o compilador no seu computador pessoal.


INSTALANDO O COMPILADOR

Faça o download do compilador gpt no link abaixo. Instale o compilador mantendo as opções padrão do instalador.

Instale o notepad++ para escrever os algoritmos nesse editor de texto simples. Baixe o programa abaixo.
http://www.4shared.com/file/ssK7DK82/npp598Installer.html
Instale esses programas nessa sequência com as opções padrão, ou seja, primeiramente instale o gpt e em seguida o Notepad++.

Caso queira maiores detalhes sobre o compilador, visite a página do projeto do gpt, abaixo.
http://gpt.berlios.de/site/


TESTANDO O COMPILADOR
Abra o notepad++ e escolha a linguagem g-Portugol. 


Digite o algoritmo abaixo:
algoritmo teste;
início
imprima("Esse eh meu primeiro programa em Portugol!");
fim


salve o algoritmo clicando em arquivo --> salvar!

Em seguida interprete o algoritmo para verificar seu funcionamento, conforme figura abaixo.


O resultado do algoritmo é mostrado numa janela preta do DOS.
A frase será impressa na tela,conforme abaixo.






OBS: Sempre que abrir o notepad++ selecione a linguagem G-portugol.
OBS: CASO VOCÊ FEZ CONFORME ACIMA E AINDA NÃO FUNCIONA, CLIQUE NO MENU FORMATAR  E CLIQUE EM "Codificação em UTF-8 (Sem BOM)".


DOCUMENTAÇÃO DO G-PORTUGOL
Uma documentação básica encontra-se em:
http://gpt.berlios.de/manual_big/manual.html


Vídeos demonstrativos encontram-se em :
http://gpt.berlios.de/site/?q=demo


CÓDIGO FONTE EXEMPLO EM PORTUGOL: MÉDIA DA FANOR 
algoritmo mediafanor;
variáveis
    np1:real;
    np2:real;
    media:real;
    examefinal:real;
    mediafinal:real;
fim-variáveis

início
    imprima("Digite as duas np's");
    np1:=leia();
    np2:=leia();
    media:=(np1+np2)/2;
    se media < 4 então
        imprima("Reprovado direto!");
    fim-se
    se media >=7 então
        imprima("Passou Direto!");
    fim-se
    se media >=4 e media < 7 então
        imprima("Digite a nota do exame final");
        examefinal:=leia();
        mediafinal:=(examefinal*0.4)+(media*0.6);
        se mediafinal >=5 então
            imprima("Passou com conceito B!");
        senão
            imprima("Infelizmente foi reprovado na final!");
        fim-se
    fim-se
fim


Bom proveito do G-Portugol.

1 comentários:

replicas relogios disse...

telasmosquiteira-sp.com.br

telas mosquiteira
telas mosquiteiro

As telas mosquiteira sp , telas mosquiteiro sp garantem ar puro por toda casa livrando-a completamente dos mosquitos e insetos indesejáveis. As telas mosquiteira garantem um sono tranquilo a toda família, livrando e protegendo-nas dos mais diversos insetos. Muitos destes insetos são transmissores de doenças e a tela mosquiteira é indispensável no combate a mosquitos transmissores de doenças.

A dengue, por exemplo, já matou centenas de pessoas só na capital de São Paulo e um pequeno investimento em nossas telas mosquiteiras podem salvar vidas. As telas mosquiteiras também impedem a entrada de insetos peçonhentos como as aranhas e os escorpiões, estes insetos também oferecem risco, pois seu veneno em poucos minutos podem levar uma criança a morte.
telas mosquiteira jundiai
telas mosquiteiro jundiai
telas mosquiteira São Paulo
telas mosquiteiro São Paulo
telas mosquiteira granja viana
telas mosquiteiro granja vinana
telas mosquiteira cotia
telas mosquiteiro cotia
telas mosquiteira sao paulo
telas mosquiteiro sao paulo

A chegada da temporada Primavera/Verão traz consigo a elevação da temperatura e a maior ocorrência de chuvas. Mas não é só isso. As estações mais quentes do ano causam muita dor de cabeça e muitos zumbidos indesejáveis em função das pragas urbanas – pernilongos, baratas, cupins e outros insetos -, que afetam todas as regiões brasileiras.

Nossa missão é oferecer telas mosquiteiras de qualidade a um preço acessível, fazendo com que as telas mosquiteiras sejam uma opção viável para muitas pessoas.

telas mosquiteiras Jundiaí
telas mosquiteiro Jundiai
telas mosquiteiras jundiai
telas mosquiteiro industria
telas mosquiteira restaurante
telas mosquiteiro restaurante
telas mosquiteira empresa
telas mosquiteiro empresa

Postar um comentário

 
PROF. EMANNUEL FERNANDES, MS. Design by Wpthemedesigner. Converted To Blogger Template By Anshul Tested by Blogger Templates.