Sejam bem vindos!

Este site é feito para auxiliar nas disciplinas ministradas por mim. Agradeço a sua visita.

segunda-feira, 18 de abril de 2011

Disciplina de Algoritmos Computacionais - Algoritmo Portugol

Olá turma, disponibilizarei informações importantes e material de apoio nesse site.

Todos os alunos tem que aprender a escrever um código fonte .gpt no notepad e compilar através do gpt,  mas para que isso possa ocorrer vocês devem instalar o compilador no seu computador pessoal.


INSTALANDO O COMPILADOR
Faça o download do compilador gpt no link abaixo. Instale o compilador mantendo as opções padrão do instalador.

Instale o notepad++ para escrever os algoritmos nesse editor de texto simples. Baixe o programa abaixo.
http://www.4shared.com/file/ssK7DK82/npp598Installer.html
Instale esses programas nessa sequência com as opções padrão, ou seja, primeiramente instale o gpt e em seguida o Notepad++.

Caso queira maiores detalhes sobre o compilador, visite a página do projeto do gpt, abaixo.
http://gpt.berlios.de/site/


TESTANDO O COMPILADOR
Abra o notepad++ e escolha a linguagem g-Portugol. 


Digite o algoritmo abaixo:
algoritmo teste;
início
imprima("Esse eh meu primeiro programa em Portugol!");
fim


salve o algoritmo clicando em arquivo --> salvar!

Em seguida interprete o algoritmo para verificar seu funcionamento, conforme figura abaixo.


O resultado do algoritmo é mostrado numa janela preta do DOS.
A frase será impressa na tela,conforme abaixo.






OBS: Sempre que abrir o notepad++ selecione a linguagem G-portugol.
OBS: CASO VOCÊ FEZ CONFORME ACIMA E AINDA NÃO FUNCIONA, CLIQUE NO MENU FORMATAR  E CLIQUE EM "Codificação em UTF-8 (Sem BOM)".


DOCUMENTAÇÃO DO G-PORTUGOL
Uma documentação básica encontra-se em:
http://gpt.berlios.de/manual_big/manual.html


Vídeos demonstrativos encontram-se em :
http://gpt.berlios.de/site/?q=demo


CÓDIGO FONTE EXEMPLO EM PORTUGOL: MÉDIA DA FANOR 
algoritmo mediafanor;
variáveis
    np1:real;
    np2:real;
    media:real;
    examefinal:real;
    mediafinal:real;
fim-variáveis

início
    imprima("Digite as duas np's");
    np1:=leia();
    np2:=leia();
    media:=(np1+np2)/2;
    se media < 4 então
        imprima("Reprovado direto!");
    fim-se
    se media >=7 então
        imprima("Passou Direto!");
    fim-se
    se media >=4 e media < 7 então
        imprima("Digite a nota do exame final");
        examefinal:=leia();
        mediafinal:=(examefinal*0.4)+(media*0.6);
        se mediafinal >=5 então
            imprima("Passou com conceito B!");
        senão
            imprima("Infelizmente foi reprovado na final!");
        fim-se
    fim-se
fim


Bom proveito do G-Portugol.

Laboratório de Máquinas Elétricas

Olá turmas,

Em breve estaremos postando material auxiliar para a disciplina de Laboratório de Máquinas Elétricas. Estaremos utilizando esta postagem para troca de informações. Fiquem a vontade caso queiram entrar em contato através dos comentários no final da página.

Att.
Emannuel J. Fernandes

Laboratório de Conversão de Energia

Olá turmas,

Em breve estaremos postando material auxiliar para a disciplina de Laboratório de Conversão de energia. Estaremos utilizando esta postagem para troca de informações. Fiquem a vontade caso queiram entrar em contato através dos comentários no final da página.

Att.
Emannuel J. Fernandes
 
PROF. EMANNUEL FERNANDES, MS. Design by Wpthemedesigner. Converted To Blogger Template By Anshul Tested by Blogger Templates.